Thread Rating:
  • 1 Vote(s) - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5

OpenWRT 21.02 squashfs for ath79 4MB devices (-tiny) with LuCI
#1

This is a package of OpenWRT 21.02.3 stable builds for targets ath79.

Modifications against default tiny packages:
  • removed PPP support
  • removed OPKG
  • removed SSL support
  • removed signature checking, etc.
  • removed swapoff and long options support from busybox
  • stripped to bare bones
  • added LuCI
  • flashing from LuCI switched off (it causes devices to freeze)

This way the builds could fit into squashfs (factory/sysupgrade) compatible builds. Relayd or wpad-basic could not fit in anymore.

Please note there is still upgrading incompatibility against deprecated target ar71xx (OpenWRT version 18.06 or older), please see https://openwrt.org/docs/guide-user/inst...x.to.ath79 for more info.

Backup your configuration via webserver, but flash new upgrades using SSH. Webserver most likely doesn't have enough memory to handle file upload as all my tests resulted in the need to reboot the device entirely.

Code:
  ssh root@192.168.1.1 #or use PuTTY
  grep machine /proc/cpuinfo #check device identification
  cd /tmp
  wget HTTP-URL #copy URL from browser, HTTPS won't work
  sysupgrade -v openwrt- #use TAB to autocomplete filename


If you are unable to log into LuCI, you probably have old /etc/config/uhttpd file present and there are attempts to redirect you to HTTPS protocol. Remove it (use rm /etc/config/uhttpd) and re-flash using the guide above.

Builds have not been tested for all devices, but compiling resulted in no errors.


https://openwrt.ashus.net/21.02.3-target...tiny-luci/
For wget in console you can use extra configured non-secure source http://openwrt.ashus.net/21.02.3-targets...tiny-luci/

[Image: kavove-zrnka-lajna.jpg]
Coffee phreak!
Reply
#2

Hi man, thanks for your firmware build.


I'm a newbie and currently running official openwrt 18.06 on my WA901ND v3. I'm interested to install this firmware on my WA901ND v3, can i immediately install it from my current openwrt 18.06 thru luci? or i need revert to the tp link stock firmware before install this firmware?
Reply
#3

(21.1.2022 12:36)sandalswallow Wrote:  Hi man, thanks for your firmware build.


I'm a newbie and currently running official openwrt 18.06 on my WA901ND v3. I'm interested to install this firmware on my WA901ND v3, can i immediately install it from my current openwrt 18.06 thru luci? or i need revert to the tp link stock firmware before install this firmware?

You can use openwrt-ath79-tiny-tplink_tl-wa901nd-v3-squashfs-sysupgrade.bin and flash directly from another OpenWRT via web interface or SSH without keeping data. Then do careful restore each configuration part at a time from your backup. Subsequent flashes to new versions will have to be done via SSH.

[Image: kavove-zrnka-lajna.jpg]
Coffee phreak!
Reply
#4

(22.1.2022 02:02)Ashus Wrote:  
(21.1.2022 12:36)sandalswallow Wrote:  Hi man, thanks for your firmware build.


I'm a newbie and currently running official openwrt 18.06 on my WA901ND v3. I'm interested to install this firmware on my WA901ND v3, can i immediately install it from my current openwrt 18.06 thru luci? or i need revert to the tp link stock firmware before install this firmware?

You can use openwrt-ath79-tiny-tplink_tl-wa901nd-v3-squashfs-sysupgrade.bin and flash directly from another OpenWRT via web interface or SSH without keeping data. Then do careful restore each configuration part at a time from your backup. Subsequent flashes to new versions will have to be done via SSH.

thanks for confirmation sir. i'm actually almost doing that (according openwrt upgrade instruction) but i'm not really sure if those guide only for official firmware or for another non official firmware as well, so i decided to wait your confirmation for a night lmao.

once again, thank you sir and sorry for my horrible english. cheers
Reply
#5

I need openwrt-ath79-tiny-tplink_tl-wr941nd-v6-squashfs-factory.bin have wpad-mesh-openssl  or wpad (full) and remove IPv6 use for full fast roaming multi APs (need 802.11kvr). Please help me! Thank...
Reply
#6

(9.3.2022 06:49)vanminh0311@gmail.com Wrote:  I need openwrt-ath79-tiny-tplink_tl-wr941nd-v6-squashfs-factory.bin have wpad-mesh-openssl  or wpad (full) and remove IPv6 use for full fast roaming multi APs (need 802.11kvr). Please help me! Thank...

The same need. I would like to use these device's tiny firmwares with mesh/roaming feature
Please Can you build or give me a hint to build firmwares
Reply
#7

You probably need to set up a linux virtual machine and build it yourself. You can use the "config" files I attach to various ROMs - they just need to be renamed to ".config". Then you can do your modifications and try to make them all fit, but I don't have enough time to do this for you.

https://openwrt.org/docs/guide-developer...uild-guide
https://openwrt.org/docs/guide-developer...uildsystem
https://openwrt.org/docs/guide-developer...uildsystem

[Image: kavove-zrnka-lajna.jpg]
Coffee phreak!
Reply




Users browsing this thread: 1 Guest(s)