• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Call Of Duty: PHP RCon 2.40 EN++
hnenad: Those pre lines are there not just for debug. There is a bug in the protocol and long responses usually become corrupted (that's what the brown block represents). To make it more customizable it would need some serious rewriting, sorry.
[Image: kavove-zrnka-lajna.jpg]
Coffee phreak!
  Reply
can i change the font style ?

[Image: Qn83LOU.png]
  Reply
I guess you can, modify your style in CSS file.
[Image: kavove-zrnka-lajna.jpg]
Coffee phreak!
  Reply
How can i warn player with his tag like this ,

Console : clientname warning reason : fast fire admin : admin name
  Reply
hello ,

I have problem with getting playername . I'm used this '. htmlspecialchars($i_username) .' for get player name but it's showing only username without colors .

Example : ^1P^2layer^6name and it's show only Playername .

I want to know how to get playername with color codes . thanks
  Reply
xox: Maybe you're looking for the function ColorizeName in /action.php.
[Image: kavove-zrnka-lajna.jpg]
Coffee phreak!
  Reply
Hi!

You may need to adjust it to develop CoD4 x 1.7a server.
It would be necessary.

Thanks.

Sorry my bad English.
  Reply
I just updated my VPS from CentOS 5 to 6 and I am now getting the dreaded "cannot connect to server error" . The scripts have been working fine for many years up to this point.

I tried forcing the PHP version down to 5.3 using the .htaccess file to no avail. What am I missing here?

I can't find any documentation that references and differences in sending raw UDP packets....
  Reply
anubis: I don't know, maybe new firewall was set up during the upgrade? I'm running this application on PHP 7 now and without any similar problems. Check your php.ini for disabled functions.
[Image: kavove-zrnka-lajna.jpg]
Coffee phreak!
  Reply
Thanks for the quick reply. Good suggestions.

PHP.ini looks OK, firewall not blocking. Gameserver answers a ping so I know regular UDP packets are working. Raw? No so sure.

I had read that Centos / RHEL 6 had some restrictions on raw packets so I edited the /etc/sysctl.conf file and added the lines "net.ipv4.eth0.rp_filter = 1" and "net.ipv4.eth1.rp_filter = 0" and rebooted the server. Nada.

Output of the "ss -s" command:

Total: 3137 (kernel 0)
TCP: 747 (estab 6, closed 697, orphaned 0, synrecv 0, timewait 66/0), ports 0

Transport Total IP IPv6
* 0 - -
RAW 0 0 0
UDP 6 5 1
TCP 50 36 14
INET 56 41 15
FRAG 0 0 0

Do you think that I am on the right track here?

I have found a few Perl scripts that will test raw UDP so that should rule out any issues with PHP and firewalls. Hopefully we can solve this and help others that are having the same issue.

EDIT: ifconfig shows "vnet0:0" as opposed to the more common "eth0:0" which makes sense since this is a virtual machine. I'll try editing "/etc/sysctl.conf " with the correct parameters.
  Reply




Users browsing this thread: 4 Guest(s)